Slammed Enuff?

A forum dedicated to the members and fans of slammedenuff?
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 Help, no sound from subs!

View previous topic View next topic Go down 
AuthorMessage
ThumperGSR

avatar

Posts : 31
Join date : 2010-11-24
Age : 28
Location : Olive Branch

PostSubject: Help, no sound from subs!   Sat Mar 05, 2011 6:59 pm

I need help with my subs. I have 2 10' Rocker fosgate's and they just stopped working a few months ago. The battery capacitor and amp have power and everything is plugged up. I checked the back of the radio and the cables are attached. I unplugged everything and replugged it back up and still nothing....

help.
what can I do to tell if its... the radio outputs that went out, the subs gone, or a wiring problem???
Back to top Go down
View user profile
Deepsouthhybrid



Posts : 179
Join date : 2010-12-16
Age : 40
Location : Corinth ms

PostSubject: Re: Help, no sound from subs!   Sat Mar 05, 2011 7:02 pm

Check thefuse on the amp and pull the subs out of the box to see if there hooked inside or it might b the RCA plugs themselves.
Back to top Go down
View user profile
ThumperGSR

avatar

Posts : 31
Join date : 2010-11-24
Age : 28
Location : Olive Branch

PostSubject: Re: Help, no sound from subs!   Sun Mar 06, 2011 4:31 pm

I checked all the fuses just now and they all work. I'm gonna try to find someone that has some spare RCA cables so I can test to see if they are wore out. I need to find a sub to test my wires on and if it works then I know it's the subs.
Back to top Go down
View user profile
Deepsouthhybrid



Posts : 179
Join date : 2010-12-16
Age : 40
Location : Corinth ms

PostSubject: Re: Help, no sound from subs!   Sun Mar 06, 2011 4:41 pm

Im gonna say it's either the amp itself or the rca's wish I was closer I would try to fix it for ya.
Back to top Go down
View user profile
ThumperGSR

avatar

Posts : 31
Join date : 2010-11-24
Age : 28
Location : Olive Branch

PostSubject: Re: Help, no sound from subs!   Mon Mar 07, 2011 7:24 pm

Well it doesn't matter now cause on my way to bestbuy, the escorts radiator cracked...awesome
Back to top Go down
View user profile
Deepsouthhybrid



Posts : 179
Join date : 2010-12-16
Age : 40
Location : Corinth ms

PostSubject: Re: Help, no sound from subs!   Tue Mar 08, 2011 6:16 pm

That Sux.
Back to top Go down
View user profile
twistedcreationsprez

avatar

Posts : 13
Join date : 2011-03-14
Age : 27
Location : Olive Branch, MS

PostSubject: Re: Help, no sound from subs!   Wed Mar 23, 2011 9:48 pm

Could be a bad wire but more than likely it's the amp. I've had this problem a few times where amps have gone out. What type of amp is it?
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Help, no sound from subs!   

Back to top Go down
 
Help, no sound from subs!
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Right channel does not sound nearly as loud as the left
» Sculptress of Sound: The Lost Works of Delia Derbyshire
» zenith royal 3000 no stations no sound
» The sound of coyote in the night
» Cool Song of Storms Sound

Permissions in this forum:You cannot reply to topics in this forum
Slammed Enuff? :: Technical :: Audio/Video-
Jump to: